Problem with gear channel on DX6i.

Please post all questions and answers in here. This way people can easily see if someone else has the same problem.

Moderators: BeligerAnt, petec, administrator

Post Reply
Posts: 829
Joined: Mon Jun 09, 2003 12:00 am
Location: Coventry

Problem with gear channel on DX6i.

Post by EpicentrE »

I'm currently working on the electronics for Void's suction pump. The plan was to use it from the gear channel on the TX, so it would just be a simple on/off, however I simply can't get it to work. Putting a servo on the gear channel works fine, and putting the ESC on the throttle channel works fine, but the ESC refuses to work on the gear channel.

You have to calibrate the controller by turning it on when the stick is at the bottom, then going to the top of the travel, then back to the bottom again. After this it will work. One theory was that because the gear channel goes straight from -100% to +100%, it didn't like it, but I've tried it on the throttle channel using throttle cut to imitate the same behaviour, and it was fine. I've also tried doing it both ways (ie -100% > +100% > -100%, and vice versa) when calibrating, to no avail.

It's not a loose connection, as I've checked, tested, and re-tested multiple times and they're all fine.

I'm getting to the point where I'm wondering if there's something inherently different with the gear channel that might cause an ESC to be confused or not work on it. I've tried all possible permutations that I can think of, and I simply can't get it to respond whatsoever when connected to the gear channel. As stated earlier, a servo works flawlessly. If anyone has any idea of what this could be, or suggestions on things I could try, I'd be most grateful, since I've been messing with it for a few hours now to no avail.

Thanks in advance.

Edit: Additional details:

TX: Spektrum DX6i
RX: AR6300
ESC: Micro Invent MSC2

Edit2: Typical, literally a minute after I posted this, I was re-reading the AR6300 manual and a thought occured to me. I thought the gear channel on the RX might be failsafing to the high position until it had connected to the TX, and then the ESC couldn't calibrate, as it has to start on low. Sure enough, I re-bound it with the gear channel set to off to set that as the failsafe, and now it works.

Sorry for the waste of forum space, you're welcome to delete this unless you think it'll come in handy to others :P.
Scott Fyfe-Jamieson, Captain of Epic Robotics. Champion of AWS38/41/42.

Post Reply