Fix on the forum viewing profiles bug?

Please post all questions and answers in here. This way people can easily see if someone else has the same problem.

Moderators: administrator, BeligerAnt, petec

User avatar
Shakey
Posts: 1087
Joined: Sat Mar 13, 2010 8:38 pm
Location: Reading

Fix on the forum viewing profiles bug?

Post by Shakey » Thu Jul 09, 2015 9:47 pm

Didn't know where to put it so here it is.

Is there any ETA or update on the bug for where clicking on someones username throws up an error rather than showing their profile? It makes it a bit more difficult to find certain bits of information people need and communicate with people.
Nuts And Bots - For all your components and ready built antweights!

Alex Shakespeare - Team Shakey / Nuts And Bots / Team Nuts:
AWS 44, 45, 49, 51 & 55 Winner - Far too many robots!

User avatar
BeligerAnt
Posts: 2464
Joined: Wed May 15, 2002 12:00 am
Location: Brighton
Contact:

Re: Fix on the forum viewing profiles bug?

Post by BeligerAnt » Thu Jul 16, 2015 6:41 pm

I'm guessing PeteC is rather busy with his new job...

However, you can get to your own profile by going to your private messages (yes really!).
On the left there is an Options panel.
Click on the Profile heading in the panel.
This then allows editing of profile, signature, avatar and account settings (password etc).

I can't find a way around viewing the profiles of others yet. From the error message it looks like Pete has broken something in the underlying code :(
Gary, Team BeligerAnt

EpicentrE
Posts: 1079
Joined: Mon Jun 09, 2003 12:00 am
Location: Coventry
Contact:

Re: Fix on the forum viewing profiles bug?

Post by EpicentrE » Thu Jul 16, 2015 6:58 pm

While we're at it, none of the buttons for adding formatting or code into posts (quote, url, img, etc.) work.
Scott Fyfe-Jamieson, Captain of Epic Robotics. Champion of AWS38/41/42.
http://www.epicrobotics.co.uk

Remote-Controlled Dave
Posts: 3716
Joined: Sun Apr 03, 2005 5:30 pm
Location: Antrim, Northern Ireland
Contact:

Re: Fix on the forum viewing profiles bug?

Post by Remote-Controlled Dave » Thu Jul 16, 2015 7:25 pm

I said that months ago but was told it was just me. But they don't work for me whichever browser or device I go through.
Die Gracefully Robotics
Winner - AWS 39

Rapidrory
Posts: 1160
Joined: Sun Nov 24, 2013 9:54 pm

Re: Fix on the forum viewing profiles bug?

Post by Rapidrory » Thu Jul 16, 2015 8:05 pm

Yeah, my emoticons and style buttons are inactive, but I've heard other people's work fine..
Rory Mangles - Team Nuts

Robots: Nuts 2 and many more...

NanoTwo Motor Controllers: https://nutsandbots.co.uk/product/nanotwodualesc

User avatar
Shakey
Posts: 1087
Joined: Sat Mar 13, 2010 8:38 pm
Location: Reading

Re: Fix on the forum viewing profiles bug?

Post by Shakey » Thu Jul 16, 2015 9:04 pm

My emoticons and style buttons are also buggared. At least I know my BBC code :P

I get that real life gets in the way of things but the profile fix is a pretty seriously needed one.
Nuts And Bots - For all your components and ready built antweights!

Alex Shakespeare - Team Shakey / Nuts And Bots / Team Nuts:
AWS 44, 45, 49, 51 & 55 Winner - Far too many robots!

User avatar
BeligerAnt
Posts: 2464
Joined: Wed May 15, 2002 12:00 am
Location: Brighton
Contact:

Re: Fix on the forum viewing profiles bug?

Post by BeligerAnt » Thu Jul 16, 2015 9:43 pm

If your emoticon and style buttons don't work, do you have Javascript enabled in your browser? You can check here

BTW emoticons and style buttons work for me :)

It's also worth checking in the bottom-left corner of the post editor window. Check that all the options are set to ON. Also check that the "Disable BBCode" and "Disable smilies" check boxes are not ticked.

I can't find anything in the forum settings or the user settings for Dave, Rory or Alex that would stop the buttons from working. Has anyone tried different phpBB-based forums, browsers, devices etc to try to diagnose the problem?

You can still use styles and emoticons by typing them manually. I've added spaces between the characters so that they don't get interpreted as codes, remove the spaces if you want to use them (and be sure to add a space before and after).

[ b ] bold [ /b ]
[ i ] italics [ /i ]
[ u ] underline [ /u ]
[ quote ] quote [ /quote ]
[ code ] code [ /code ]
[ list ] [ * ] list item [ /list ]
[ img ] http://image_url [ /img ]
[ url=http://url ] link [ /url ]
[ size=50 ] tiny text [ /size ]
[ size=85 ] small text [ /size ]
[ size=150 ] large text [ /size ]
[ size=200 ] huge text [ /size ]

: D :D
: ) :)
: ( :(
: o :o
: - ? :-?
8 ) 8)
: lol : :lol:
: x :x
: P :P
: oops : :oops:
: cry : :cry:
: evil : :evil:
: roll : :roll:
: wink : :wink:
Gary, Team BeligerAnt

User avatar
Shakey
Posts: 1087
Joined: Sat Mar 13, 2010 8:38 pm
Location: Reading

Re: Fix on the forum viewing profiles bug?

Post by Shakey » Thu Jul 16, 2015 9:55 pm

Javascript is indeed enabled. I double checked to be sure. And BBC code and disable smilies are both not ticked.

Running google chrome. All the other phpBB based forums I browse do not suffer this problem.
Nuts And Bots - For all your components and ready built antweights!

Alex Shakespeare - Team Shakey / Nuts And Bots / Team Nuts:
AWS 44, 45, 49, 51 & 55 Winner - Far too many robots!

User avatar
BeligerAnt
Posts: 2464
Joined: Wed May 15, 2002 12:00 am
Location: Brighton
Contact:

Re: Fix on the forum viewing profiles bug?

Post by BeligerAnt » Thu Jul 16, 2015 10:01 pm

Curious. It works for me in Chrome and Firefox. I really don't understand why it works for some users and not others. Everyone has the same (default) forum permissions, the only exceptions are admins and moderators. One for PeteC...
Gary, Team BeligerAnt

EpicentrE
Posts: 1079
Joined: Mon Jun 09, 2003 12:00 am
Location: Coventry
Contact:

Re: Fix on the forum viewing profiles bug?

Post by EpicentrE » Thu Jul 16, 2015 10:03 pm

Shakey wrote:BBC code
No, not a recursive acronym! Anything but that! The horror! D:
Scott Fyfe-Jamieson, Captain of Epic Robotics. Champion of AWS38/41/42.
http://www.epicrobotics.co.uk

Post Reply